ЕГЭ по информатике - на 101 балл!

Задачa для решения на Python, содержит решение-ответ

301

Сумма цифр натурального числа

Pavlov Легкая сложность id: 301 25.11.2025

Напишите программу, которая находит сумму цифр натурального числа (например, п = 123456789)

Программа должна обрабатывать натуральные числа любой длины.

Решение:

Функциональный стиль

n = 123456789
print(sum(map(int, str(n)))) # 45

Возможные решения:

Генератор

n = 123456789
print(sum(int(d) for d in str(n))) # 45

Креативный

n = 123456789
print(eval('+'.join(str(n)))) # 45

Математический

n = 123456789
s=0
while n>0:
    s+=n%10
    n//=10
print(s) # 45
Все задачи Учебника PYTHON в ЕГЭ