ЕГЭ по информатике - на 101 балл!

Задачa для решения на Python, содержит решение-ответ

302

Пары элементов в списке

Pavlov Средняя сложность id: 302 19.12.2024

Напишите программу, которая в списке натуральных чисел определит количество таких пар чисел, в которых первый элемент пары больше второго. Под парой подразумевается два числа, стоящие рядом.
Пример списка: s = [12, 1564, 54, 546, 84, 123, 456, 789, 1, 96, 12]

Программа должна корректно обрабатывать список любой длины.

Решение:

Функциональный стиль

s = [12, 1564, 54, 546, 84, 123, 456, 789, 1, 96, 12]
print(sum(1 for a, b in zip(s, s[1:]) if a > b)) # Ответ: 4

Возможные решения:

Императивный стиль

s = [12, 1564, 54, 546, 84, 123, 456, 789, 1, 96, 12]
k = 0
for a, b in zip(s, s[1:]):
    if a > b:
        k += 1
print(k) # Ответ: 4

Решение через индексы

s = [12, 1564, 54, 546, 84, 123, 456, 789, 1, 96, 12]
k = 0
    for i in range(len(s) - 1):
        if s[i] > s[i + 1]:
            k += 1
    print(k) # Ответ: 4
Все задачи Учебника PYTHON в ЕГЭ