ЕГЭ по информатике - на 101 балл!

Задачa для решения на Python, содержит решение-ответ

303

Трёхбуквенные слова из букв слова 'ЛОГИКА'

Pavlov Легкая сложность id: 303 25.11.2025

Напишите программу, которая определит, сколько можно составить различных трёхбуквенных слов из букв слова “ЛОГИКА”, в которых каждая буква встречается не более одного раза.

Под словом в данной задаче подразумевается любая комбинация букв, не обязательно осмысленная.

Решение:

from itertools import permutations
print(sum(1 for _ in permutations('ЛОГИКА', 3))) # 120

Возможные решения:

Более читаемый вариант с permutations

from itertools import permutations
print(len(list(permutations('ЛОГИКА', 3)))  # 120

Аналитическое решение

На первую позицию можно поставить любую из 6 букв
На вторую позицию - любую из оставшихся 5 букв
На третью позицию - любую из оставшихся 4 букв

6 × 5 × 4 = 120

Ручной перебор с циклами (не рекомндуется)

word = 'ЛОГИКА'
count = 0
for i in range(len(word)):
    for j in range(len(word)):
        if j != i:
            for k in range(len(word)):
                if k != i and k != j:
                    count += 1
print(count)  # 120
Все задачи Учебника PYTHON в ЕГЭ